Dave Bullock / eecue

photographer, director of engineering: crowdrise, photojournalist, hacker, nerd, geek, human

My Adventures with Leopard : /home, Epson 3800, ATSServer

I'm an early adopter. When the OS X Beta came out in 1999 I jumped right on it, being a FreeBSD user I was right at home with the BSD subsystem and command line. When Leopard arrived via FedEx at my office yesterday I hesitated only slightly before installing it.

I asked some of my other nerd friends if they had encountered any problems, and I took at look at Apple's discussion forums, paying particular notice to this issue, which currently has over 350 replies and 25,000 views. One of my friends said that if I ran the disk utility from the Leopard install disk before I upgraded it would solve that problem. I ran disk utility, it found a problem and fixed it and I had no trouble upgrading.

Once my system booted up I went through all my applications and checked to see if they functioned properly, and everything did until I got to Zend Development Engine, which opened up fine, but my project had no files in it! I try to add them back to the project, but when I went to /home I noticed that it was totally empty! I thought that the upgrade had delete my web development files, and I was pissed, but luckily I had a backup that wasn't too old, and most all of my projects are in CVS, SVN or git repositories. I posted this thread on the Apple discussion forums and the next day I got the following response which restored my /home directory and all its contents!:

The good news is that your files are still on the drive. This is because 10.5 is now a real, certified Unix OS. However, I think that the default setting should have been to preserve the /home as a local directory. See the explanation here.

That worked, my files in /home were unharmed, Apple's new "real UNIX" features caused an invisible volume to be mounted using /home as the mount point.

My next problem came when I tried to print to my Epson 3800, I downloaded the new drivers from Epson's website (they have a 10.5 driver) and installed it. Now when I tried to print to the 3800 the printer was auto-detected but I still couldn't print. I'm sure this will be fixed shortly and it's not an emergency for me.

The third issue I noticed this morning was that ATSServer was using 185% of my processing power (I have a Core Duo MacBook Pro). Right now it's not a huge deal as I'm about to go out to take some photos anyhow, but this could put a damper on activities that do require my processors full attention like working with RAW files in Lightroom.

All in all, I'm very happy with Leopard's new features. The system is actually faster, if you can believe that! Moving around windows, loading websites and opening applications seem to work much more smoothly than before. This is a great update from Apple, I'm sure they'll work out the kinks soon. They did just release a Software Update to fix the login problems and the 802.11 issues, none of which affected me.

Update: I forgot to mention, I check my mail through an ssh tunnel to my IMAP server and I've been getting server timeout warnings. My server isn't actually timing out though, and this was never an issue in Tiger... I'm guessing Leopard's Mail.app is just more sensitive. It actually hasn't been a problem this weekend, only on Friday.